Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


  • Find by combination Ctrl+F line #Listen 12.34.56.78:80 and change the 80 to any you like for example 81
  • Go to C:\xampp\apache\conf\extra\httpd-vhosts and change 80 to 81

You can change the port of apache:

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


  • Change the port 80 to 9000 or 81 or whatever you want in httpd.conf on the line Listen 80
  • Change the port on httpd-ssl.conf and change Listen 443 to Listen 441
  • Open XAMPP and select config in apache service
  • restart XAMPP and start apache service, and it work for me.

Good catch - ensure the http and https ports are not in conflict

It looks like there are many options answer it is depend on your windows. Here is my experience when having the same problem in windows 10 fresh install and fix the issue with the following step :

NOTE : I'm using XAMPP Version 5.6.15 and XAMPP Control Panel version 3.2.2

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


  • Go to run/search in windows10
  • On that list untick the Internet Information Service(IIS)

In my case it was a simple case of removing IIS because windows 10 comes with IIS pre installed - that conflicts with XAMPP because these both servers try to use the port 80. If you dont want to use IIS and keep using XAMPP

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


  • Go to run/search in windows10
  • On that list untick the Internet Information Service(IIS)

In my case it was a simple case of removing IIS because windows 10 comes with IIS pre installed - that conflicts with XAMPP because these both servers try to use the port 80. If you dont want to use IIS and keep using XAMPP

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


Update : 4th August, 2015 :

  • Go to Start, type in services.msc

For those outthere using the Uniform server Z (which is great!), I can confirm this working for that server too.

I was facing a similar problem with WAMP. In Windows 10 TP, the Word Wide Web Publishing Service comes pre-installed. This is related to IIS and you can remove it if you don't need it.

If it doesn't, try installing Visual C++ Redistributable and then re-install WAMP/XAMPP.

If you have done clean installation of Windows 10, you may not have the Word Wide Web Publishing Service. In that case, simple WAMP/XAMPP installation should work fine.

The name of the service is W3SVC while the description is World Wide Web Publishing Service. I initially did not think I had the service because I was not seeing the service described when sorting by name.

This blocks the port 80 making Apache act weirdly. You can do the following and try again.

This should make port 80 free and restarting WAMP/XAMPP should get you up and running!

What if I don't have "World Wide Web Publishing Service" as a service listed?

Yea, I had this problem as well, it kept telling me "A process witha PID of 4 is using port 80" when I checked it, the process name was "System". I kept thinking I could mess up my PC if i tried stopping this process. But this worked perfectly. Thanks

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


Update : 4th August, 2015 :

  • Go to Start, type in services.msc

For those outthere using the Uniform server Z (which is great!), I can confirm this working for that server too.

I was facing a similar problem with WAMP. In Windows 10 TP, the Word Wide Web Publishing Service comes pre-installed. This is related to IIS and you can remove it if you don't need it.

If it doesn't, try installing Visual C++ Redistributable and then re-install WAMP/XAMPP.

If you have done clean installation of Windows 10, you may not have the Word Wide Web Publishing Service. In that case, simple WAMP/XAMPP installation should work fine.

The name of the service is W3SVC while the description is World Wide Web Publishing Service. I initially did not think I had the service because I was not seeing the service described when sorting by name.

This blocks the port 80 making Apache act weirdly. You can do the following and try again.

This should make port 80 free and restarting WAMP/XAMPP should get you up and running!

What if I don't have "World Wide Web Publishing Service" as a service listed?

Yea, I had this problem as well, it kept telling me "A process witha PID of 4 is using port 80" when I checked it, the process name was "System". I kept thinking I could mess up my PC if i tried stopping this process. But this worked perfectly. Thanks

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


In you have installed SQL Server, Some of its services may block the port which XAMPP needs. I solved my problem by disabling SQL Server Reporting Services and now Apache starts with no problem.

Just open the services.msc , scroll down and find SQL Server Reporting Services , right click on it and click the Stop.

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
regedit

Change the value of Start to 4, which means disabled.

The Windows 10 "November Upgrade" caused my issue - all had worked before on the older version of Win 10. I didn't have W3svc running or Skype. This solution did the trick! Thanks @Do Nhu Vy!

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
regedit

Change the value of Start to 4, which means disabled.

The Windows 10 "November Upgrade" caused my issue - all had worked before on the older version of Win 10. I didn't have W3svc running or Skype. This solution did the trick! Thanks @Do Nhu Vy!

Note
Rectangle 27 0

php XAMPP : Couldn't start Apache (Windows 10)?


  • In the prompt, type net start W3SVC and Enter.
  • In the prompt, type net stop W3SVC and Enter.
  • Open a command prompt with administrator privileges

I had the same problem on Windows 10 using XAMPP. After each restart I would have to go to the XAMPP control panel and reinstall and start the Apache and MySQL services again. Running the XAMPP control panel as administrator seems to have cured it, thanks!

On the released version of Windows 10, I get "System error 3 has occurred. Access is denied."

Yep, thanks DIANGELISJ. In Windows 10, a right click on cmd and then your instructions above, then a right click on httpd.exe and I got Apache working again. The httpd.exe box is a black blank, but Apache works.

You can now click in WAMPP and restart all services. Open your browser and navigate to "localhost".

this is the correct answer, all you need to do is to shut down IIS, and then start xampp. Control-Panel - Admin - Internet Information Services - "Stop" That's it. Easy as pie. ( same thing as above, just through interfaces.)

Note