Rectangle 27 0

php .htaccess has been read but rewrite url is not working?


RewriteCond %{REQUEST_URI} /boombottleh2o.*?$

It looks like your RewriteCond expects to match http://localhost/boombottleh2o/ rather than the url you used localhost/magentodev/boombottleh2o as the REQUEST_URI string will contain /magentodev/boombottleh2o, but your regex expects to match /boombottleh2o at the very beginning of the string.

To fix the condition, you should need to remove the carat ^ at the beginning.

You're also escaping the + character towards the end of your regex. \+? will try to match the + symbol 0 or one times. I'm not sure if that was intentional, but if you use .*? instead you'll always match a request for the /boombottleh20/ folder, even if the request goes deeper or includes a file type

Note
Rectangle 27 0

php .htaccess has been read but rewrite url is not working?


C:/wamp/www/magentodev/.htaccess
ErrorDocument 404 default
Options +FollowSymLinks
RewriteEngine on

RewriteRule ^boombottleh2o(/.*)?$ gu/boombottleh2o.php [NC,L]

"not working" doesn't help fix your problem. Show the current config, the input URL, and the RewriteLog.

@covener please clarify what you need to see. where can I find the rewrite Log?

I already had follow symlink and rewrite engine, I have change rewrite rule to what you have suggested, I tried urls, it is not working

Note
Rectangle 27 0

php .htaccess has been read but rewrite url is not working?


Click on the Wamp Icon, then Apache, then modules and scroll down a bit and make sure the rewrite module has a check next to it. That fixed it for me!

Good Luck, Wamp is always trickier than it seems

I tried it, did not work, also I checked the module, it has the checked, it is installed.

This eliminates localhost as you already set that as the ServerName and You can add an alias under neath

This may sound obvious but have you tried anything with the wampmanager?

Your .htaccess file looks solid for what you're trying to accomplish, but with your vhost.conf make sure to cover all your boundaries and add a regex * at the beginning of the file

Note