Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


Sign up for our newsletter and get our top new questions delivered to your inbox (see an example).

4 years on and this is still a problem. There is absolutely nothing in the error to provide any lead on the source of the problem. I too was moving an existing solution to a new server that did not yet have the module on and it was only by chance I stumbled across this answer so thanks a bunch as I was tearing my hair out!

> I had these exact symptoms and my issue was similar to Peter's. Was setting up an existing project on a new server. My project referenced the IIS7 URL Rewriting module, but that hadn't been installed yet on the new server. Installing it fixed my issue. Thanks, DJjeffJ. Fixed it for me. URL rewirte module on dev server not installed.

I had these exact symptoms and my issue was similar to Peter's. Was setting up an existing project on a new server. My project referenced the IIS7 URL Rewriting module, but that hadn't been installed yet on the new server. Installing it fixed my issue.

Or you can download it here.

The problem continues with Server 2016, there is no feature/module to install that says "URL Rewrite". You must use the to install it, and after that my site worked (or at least stopped giving that issue).

You can use the Microsoft Web Platform Installer to install it. Execute it, select Products, in the left menu select Server and find URL Rewrite in the list and install it.

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


4 years on and this is still a problem. There is absolutely nothing in the error to provide any lead on the source of the problem. I too was moving an existing solution to a new server that did not yet have the module on and it was only by chance I stumbled across this answer so thanks a bunch as I was tearing my hair out!

> I had these exact symptoms and my issue was similar to Peter's. Was setting up an existing project on a new server. My project referenced the IIS7 URL Rewriting module, but that hadn't been installed yet on the new server. Installing it fixed my issue. Thanks, DJjeffJ. Fixed it for me. URL rewirte module on dev server not installed.

I had these exact symptoms and my issue was similar to Peter's. Was setting up an existing project on a new server. My project referenced the IIS7 URL Rewriting module, but that hadn't been installed yet on the new server. Installing it fixed my issue.

Or you can download it here.

The problem continues with Server 2016, there is no feature/module to install that says "URL Rewrite". You must use the to install it, and after that my site worked (or at least stopped giving that issue).

You can use the Microsoft Web Platform Installer to install it. Execute it, select Products, in the left menu select Server and find URL Rewrite in the list and install it.

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


Same issue on Server 2016, IIS 10, 500.19 error. I installed the redirect module and it worked. I do not know why this was not included by default.

To be clear it looks like the web.config from IIS 7 will work, or is designed to work, but the lack of this module gives the really odd and unhelpful error. Googling takes you to a Microsoft page which insists that your site is corrupted or your web.config is corrupted. Neither seems to be the case.

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


Same issue on Server 2016, IIS 10, 500.19 error. I installed the redirect module and it worked. I do not know why this was not included by default.

To be clear it looks like the web.config from IIS 7 will work, or is designed to work, but the lack of this module gives the really odd and unhelpful error. Googling takes you to a Microsoft page which insists that your site is corrupted or your web.config is corrupted. Neither seems to be the case.

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


AJAX is not properly installed in your web.config!

Aha! I beat this problem! My god, it was a beast for someone like me with limited IIS experience. I really thought I was going to be spending all weekend fixing it.

First thing to be aware of: If you're hoping this is your solution, make sure that you have the same Error Code (0x8007000d) and Config Source (-1: 0:). If not, this isn't your solution.

Found a mirror of the old content. So annoying the way MS documentation disappears so frequently.

Here's the solution for anyone else who ever comes this evil problem.

Looks like Microsoft broke that first link to configure ASP.NET AJAX.

Then, install the AJAX 1.0 extensions on your production server, from this link:

Your answer suggests that this error is ONLY for Ajax but it applies to urlrewrite also which means the error likely just refers to any suggestion which is dependant on a module that's not available.

thanks! The AJAX Extensions was the problem. I commented that section out since AJAX is now built into 3.5

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


AJAX is not properly installed in your web.config!

Aha! I beat this problem! My god, it was a beast for someone like me with limited IIS experience. I really thought I was going to be spending all weekend fixing it.

First thing to be aware of: If you're hoping this is your solution, make sure that you have the same Error Code (0x8007000d) and Config Source (-1: 0:). If not, this isn't your solution.

Found a mirror of the old content. So annoying the way MS documentation disappears so frequently.

Here's the solution for anyone else who ever comes this evil problem.

Looks like Microsoft broke that first link to configure ASP.NET AJAX.

Then, install the AJAX 1.0 extensions on your production server, from this link:

Your answer suggests that this error is ONLY for Ajax but it applies to urlrewrite also which means the error likely just refers to any suggestion which is dependant on a module that's not available.

thanks! The AJAX Extensions was the problem. I commented that section out since AJAX is now built into 3.5

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


I had the same error. I had an IIS site with .net framework version 2.0, but my app needed 4.0. I changed the version and it worked.

Posting just as a reminder if someone might have the same issue.

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


I had the same error. I had an IIS site with .net framework version 2.0, but my app needed 4.0. I changed the version and it worked.

Posting just as a reminder if someone might have the same issue.

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


> I had these exact symptoms and my issue was similar to Peter's. Was setting up an existing project on a new server. My project referenced the IIS7 URL Rewriting module, but that hadn't been installed yet on the new server. Installing it fixed my issue. Thanks, DJjeffJ. Fixed it for me. URL rewirte module on dev server not installed.

I had these exact symptoms and my issue was similar to Peter's. Was setting up an existing project on a new server. My project referenced the IIS7 URL Rewriting module, but that hadn't been installed yet on the new server. Installing it fixed my issue.

Yup... me too, I had .net 3.5 so ajax was already included, but rewriting isn't.

Note
Rectangle 27 0

iis Web Application Problems (web.config errors) HTTP 500.19 with IIS7.5 and ASP.NET v2?


My IIS 7.5 does not understand tag in web.config In VS 2010 it is underline that tag also. Check your config file accurate to find all underlined tags. I put it in the comment and error goes away.

Note