Rectangle 27 0

dotnetnuke DNN or IIS 401 Unauthorized error and some failed attempts to diagnose?


  • create a domain\user e.g. "yourDomain\dnn_yourCustomer" then

From IIS management console or the wwwroot\yourDNNinstalllocation folder set the permissions to "IIS AppPool\ApplicationPoolName" to MODIFY. Note: the windows permission will require the Location to be "your-IIS-Server-or-PC-name" rather than any Domain location.

If you did want a domain role and integrated SQL Security on your database server, then you would need to

You need to get the IIS Authentication -> Anonymous Authentication -> "Anonymous user identity" to match up to the file directory permissions. This is to allow the DNN code to execute within your file system. The recommended setting is to use "Application pool identity" to limit your IIS server/web site into other parts of your server environment.

Note
Rectangle 27 0

dotnetnuke DNN or IIS 401 Unauthorized error and some failed attempts to diagnose?


Absolutely! I took off the IUSR account and the site still worked. I think the problem I was having had to do with ignoring your pleas to not set up the database if I was using SSMS Express. So I had the App Pool tied to a database that was set to "COMPUTERNAME\SQLEXPRESS" instead of ".". I assume, honestly I'm out of my depth with all of this stuff.

Anyways, problem's fixed. Thank you, Chris, for the replies. I appreciate your help, and I look forward to diving into the rest of your tutorial videos at dnn.com

Glad you got it working! Sorry there was so much trouble with it

I did another step that I found when I Googled "IIS 401.3 unauthorized error". It said to add the IUSR user to the security settings on the dnndev.me folder. I'm not sure if this played any role in fixing things, but it didn't hurt nothin' neither.

Okay, I fixed it. Maybe not "fixed it" so much as "didn't break it this time". I deleted/uninstalled everything and went back to the first video. The part I hadn't noticed before was when he says if you're using SQL Server Management Studio Express, skip the setting up a database step. So I did, and everything worked.

Would you mind doing a bit more troubleshooting? If you remove the IUSR account does the problem occur again? With IIS7/7.5, when you create a website, it creates an application pool and an identity for that pool. I don't know if IIS8 does the same or not, but you would add the security for "iis apppool\dnndev.me" with MODIFY permissions on the DNNDEV.me folder in the file system. I am wondering if that fixes the problem you are having.

Note