Rectangle 27 0

android How to solve the error "Projects created at console.firebase.google.com must use the new Firebase Authentication SDKs"?


@frank-van-puffelen This error also happens on server applications using Firebase 2. The funny part is applications create using Firebase Legacy and migrated to to Google Firebase work perfectly.

If you already have an existing project on the legacy Firebase console, you can continue to use that with the 2.x SDKs. But projects that are created at firebase.google.com, can only use the Firebase Authentication SDKs available from firebase.google.com/docs/auth.

Projects that are created at firebase.google.com, can only use the Firebase Authentication SDKs available from https://firebase.google.com/docs/auth/.

The fact that you're including a dependency on the new Firebase is not enough, you likely also have a dependency on Firebase for Android 2.x somewhere (e.g. compile 'com.firebase:firebase-client-android:2.5.2+'), which you'll need to remove.

You're using a Firebase 2.x SDK, specifically this createUser() method.

Note