Rectangle 27 0

Problems with ffmpeg command line on android?


@AkashDubey: to check if this is the same issue, run ffmpeg with no file parameters, e.g. fffmpeg -?. If you still get same java exception, it's it. If not, your problem is different, and has to do with the way you specify input or output file paths. In the latter case, feel free to open a separate question and disclose more details on how you attempt to run ffmpeg from your app.

@AlexCohn don't worry, I wasn't asking i was just telling that I was executing ffmpeg command before loading ffmpeg, that was the issue and now it is resolved

Android has a special security feature: the /mnt/sdcard filesystem is execution-protected. You cannot run an executable that is located on the external storage (a.k.a. USB storage). If you want to run ffmpeg binary on your device, you must load it into one of the internal directories. For example, you can pack it into libs/armeabi of your Java project, so that the installer will automatically unpack it into the /data/data/<your package>/lib directory on the device. Or you can find another directory, like /data/local, where you can put the executable binary file with adb push

Thanks,I put it in the root and it worked!

same issue!! I am merging two videos which are at internal storage and storing the resulting video on the same location but it gives this-java.io.IOException: No such file or directory

Note