Rectangle 27 0

Hibernate 5.2.7 java.lang.NoSuchMethodError: org.hibernate.engine.spi.SessionFactoryImplementor.getProperties()LjavautilMap;?


org.hibernate

Conflicts with the right version of the JPA 2.1 API:

This problem is caused by having an old, incompatible copy of the JPA API on the classpath.

Unfortunately Maven 3 is still unable to handle re-distributions of the same artifacts, which are sometimes necessary.

sure, feel free to search for another one, but the API is the same for all distributions as it's defined by the JPA standard.

Note