Rectangle 27 4

Is it possible that the packages have been restored to the wrong folder? Check that the paths in the csproj files are correct.

If they are different it could be caused by the packages now being restored to a different location. This could be caused by a NuGet.Config file being checked in specifying a node like this:

<add key="repositoryPath" value="..\..\Packages" />

The packages are being restored, by the projects are still looking at the old location.

I believe it could be a path issue since I did move the location of the files but I don't see where there is a hard coded path anywhere. I looked in the proj file and all the packages files seem to be relative like this: <Reference Include="Antlr3.Runtime, Version=3.5.0.2, Culture=neutral, PublicKeyToken=eb42632606e9261f, processorArchitecture=MSIL"> <SpecificVersion>False</SpecificVersion> <HintPath>..\packages\Antlr.3.5.0.2\lib\Antlr3.Runtime.dll</HintPath> </Reference>

adding this to web.config did not help: <add key="repositoryPath" value="..\..\Packages" />

You don't want to add that to the web.config. I was referring to the NuGet.config file and you want to check the relative path. Where are your packages relative to the csproj files? Are they in ..\packages? It sounds like the packages are being restored correctly, but your projects are looking in the wrong place.

visual studio 2010 - This project references NuGet package(s) that are...

visual-studio-2010 visual-studio msbuild nuget
Rectangle 27 0

There were some paths in the csproj that were broken:

<ItemGroup>
    <Reference Include="MongoDB.Bson">
      <HintPath>..\web\packages\mongocsharpdriver.1.8.3\lib\net35\MongoDB.Bson.dll</HintPath>
    </Reference>
    <Reference Include="MongoDB.Driver">
      <HintPath>..\web\packages\mongocsharpdriver.1.8.3\lib\net35\MongoDB.Driver.dll</HintPath>
    </Reference>
    <Reference Include="MongoRepository.Net45, Version=1.6.2.0, Culture=neutral, processorArchitecture=MSIL">
      <SpecificVersion>False</SpecificVersion>
      <HintPath>..\packages\MongoRepository.1.6.3\lib\net45\MongoRepository.Net45.dll</HintPath>
    </Reference>
    <Reference Include="System" />
    <Reference Include="System.Core" />
    <Reference Include="System.Xml.Linq" />
    <Reference Include="System.Data.DataSetExtensions" />
    <Reference Include="Microsoft.CSharp" />
    <Reference Include="System.Data" />
    <Reference Include="System.Xml" />
  </ItemGroup>

visual studio 2012 - AppHarbor build error with nuget packages - Stack...

visual-studio-2012 nuget bitbucket appharbor
Rectangle 27 0

Is it possible that the packages have been restored to the wrong folder? Check that the paths in the csproj files are correct.

If they are different it could be caused by the packages now being restored to a different location. This could be caused by a NuGet.Config file being checked in specifying a node like this:

<add key="repositoryPath" value="..\..\Packages" />

The packages are being restored, by the projects are still looking at the old location.

I believe it could be a path issue since I did move the location of the files but I don't see where there is a hard coded path anywhere. I looked in the proj file and all the packages files seem to be relative like this: <Reference Include="Antlr3.Runtime, Version=3.5.0.2, Culture=neutral, PublicKeyToken=eb42632606e9261f, processorArchitecture=MSIL"> <SpecificVersion>False</SpecificVersion> <HintPath>..\packages\Antlr.3.5.0.2\lib\Antlr3.Runtime.dll</HintPath> </Reference>

adding this to web.config did not help: <add key="repositoryPath" value="..\..\Packages" />

You don't want to add that to the web.config. I was referring to the NuGet.config file and you want to check the relative path. Where are your packages relative to the csproj files? Are they in ..\packages? It sounds like the packages are being restored correctly, but your projects are looking in the wrong place.

visual studio 2010 - This project references NuGet package(s) that are...

visual-studio-2010 visual-studio msbuild nuget